Steam registration button


I’m getting an access error when I click register with steam on a championship.

Here’s the error:

Access Denied

You don’t have permission to access “Steam Community” on this server.

Reference #18.4ebdd717.1680678888.7b4ff93

Could anybody help me with that?

Many thanks


I’m not sure about this one, can you access that URL normally just by clicking it or do you see the same error? If you do then for some reason Steam Community is blocked for you, perhaps try clearing your browser cache/cookies, and try disabling any VPN.

If you can access it normally then let me know and we’ll dig a bit deeper.


Hello, I am reviving the subject because I see myself confronted with this problem, in fact I created a championship with steam registration, but when a driver wants to register he either ends up with the error: Access denied or else it puts “error, please try again later”
I think it’s probably an unopened port on my router or something like that, no communication between my server and Steam, but the problem is that I looked everywhere and couldn’t find anything that solved my problem. problem, that’s why I’m calling on you, hoping that you have the solution lol.
Thank you in advance for your answer.

Bonsoir, donc j’ai trouvé la cause du problème mais je ne sais pas comment le régler, en fait lorsqu’un pilote clique sur “register with steam” ca l’emmene ici :

et ca ne fonctionne pas

Mais lorsque l’on passe par ce lien : Steam Community
Cela fonctionne

Donc peut être que quelque chose à mal été configuré au montage du serveur, mais je ne vois pas quoi ni où.


Please can you check your server_manager_base_URL and make sure that it matches the URL that you are accessing the manager at? For example, if you access the Server Manager at, your server_manager_base_URL should be set to

Once you’ve done this, please restart Server Manager and try again - the steam login should then work correctly.

Hope this helps!

Good evening, I checked and the addresses are correctly indicated.


Server access →

I just noticed that there is a question mark in the address, is this normal?

I also noticed this error that can happen

You are not authorized to access “Welcome to Steam on this server.

Reference #18.6057c817.1701971226.173198f9

It might be worth trying this without the domain, and see if that helps. To do this:

  1. Set the Server Manager to operate on your IP address, not the domain
  2. Update the server_manager_base_URL to match
  3. Restart Server Manager
  4. Open Server Manager at your IP address, e.g.
  5. Try Steam login again

If the steam login works, it means that steam don’t allow access via, so you would need to look into using a different dynamic DNS provider.

Good evening, I followed your advice and it works perfectly now, to be careful of the users who follow this manipulation because afterwards there are still other parameters to update in the server and the stracker, in any case a thank you very much, just for info could you recommend a DDNS provider that would not have this problem with steam?

I’m afraid we can’t, we have no way of knowing ourselves which DDNS providers Steam supports, you would need to get that information from them.