Other players are invisible on road, but only visible on dash?

I have the wierdest issue hosting dedicated AMS2 server.

When starting AMS2 server, the webinterface is accessable. The server shows up in game to join. upnp ports is turned on. when i join my own server, i can see other players in the joined players-list but i don’t see them on the track. the weirdest thing is: i can see them on the simhub-dash (moving player-numbers on the lap). even when i pull over on the side to wait for other players to passby, i don’t see any other cars on the track.

also i noticed the server.cfg gets overwritten eachtime i start the server and it doesn’t listen on the configured ports that i have set. i also tried to toggle upnp off/on it won’t listen.
(i want to set the hostport and queryport from 9600/1 to 9604/5 because i also host an AC and an ACC server)

i could use some help with this


This sounds like the port setup for your server is not correct. Please can you try setting some other ports and ensuring that the following port forwarding rules are set for them:

  • Steam Port: TCP only
  • Host Port: TCP and UDP
  • Query Port: TCP and UDP

Ports should be unique and not used by any other services.

Part of the normal starting process of the Server Manager is to write out its own server.cfg, so that the DedicatedServerCmd.exe knows what has been set up. All of your setup should be done inside the Server Manager, not in the server.cfg itself.

If this file is still being overwritten in a way that does not match the options you have set in the Server Manager, it sounds like something else may be using it (maybe another server install?). It may be worth looking in Task Manager to see if there are any other processes running that could be interfering with this file, or trying a reboot.

Hi seejy,

thanx for the suggestions. i dived a little deeper in the config.yml
fyi: i run the servermanger on Debian linux (virtual)
the server.cfg gets overwritten by servermanager (it’s supposed to) with settings set in servermanager.
it turned out that switching off uPNP will set the ports manually. that actually worked :blush:
Players can now see / encounter eachother on the track. still it’s hard to find my own server in the serverlist, even when i put my servername in a filter to search for. i tried just the first 4 letters or the exact full servername, i can’t find my own server most of the time, i have to stop/restart it, or switch to search LAN-games and then back to online broswer. you have to be lucky to find your own server.
is there a way to enhance that?

Hi LasPa,

Glad you got that issue solved. Unfortunately there’s not much we can do regarding the server appearing in the lobby, we have also experienced similar issues when hosting AMS2 servers on Linux, the only suggestion I have would be to look in to native Windows hosting instead.