Not loading Full Track, don't understand why

Assetto Corsa Server Manager Premium v2.3.0

I can’t seem to load this specific track.

I downloaded gunma-cycle-sports-center, which seems to come with 3 tracks.

The Full track (doesn’t show)
2 hot versions (both show)
I can’t seem to figure out why the track just refuses to show up on the server. It shows it when i upload it in the preview window…but when i go and start the server, it just isn’t there and only the 2 hot versions show up.

For reference…if i use the regular AC server, it works fine.

Any ideas? Not sure what im doing wrong.

If i delete the 2 other tracks and just try and upload the full track
I get “Sorry, looks like that wasn’t a track!”

Hi Stealth,

ACSM currently checks for a file called surfaces.ini for each layout (which defines key values for different track surfaces like friction and damping) to ensure that the layout is a valid track layout.

It looks like in the mod you linked both “hot version” layouts have a surfaces.ini file, but the “full attack” version does not, so it isn’t being imported by ACSM.

You can fix this by taking the surfaces.ini file from one of the other layouts and copying it across to the full attack layout (so from pk_gunma_cycle_sports_center\gcsc_hot_version_attack\data to pk_gunma_cycle_sports_center\gcsc_full_attack\data.

Any drivers that want to drive on the server will need to do the same though (unless you use the ACSM event form to disable all checksums), so the ideal fix would be for the mod author to update the track with a proper surfaces.ini file for each layout.


Yes that worked! thank you

but now i have a new problem. I’m getting an error saying the sectors can’t be found.
I’m using the track here

=“Couldn’t read track (Trial Mountain REDUX 2.1) splines, pit lane detection disabled” error=“open C:\Program Files (x86)\Steam\steamapps\common\assettocorsa\server\content\tracks\Trial Mountain REDUX 2.1\ai\ The system cannot find the path specified.”

Hi, I’m glad that solved it.

On your error, some tracks are missing the ai files and will cause this error, but those files aren’t required for the track to work so you should be able to use it without them. At the moment the only features you’ll be missing are pitlane detection, which is a live timings feature and drive through penalties.

Having said that, it does look to me like the track you linked does include ai files for both layouts, but the name doesn’t match what you’ve posted, the filepath should be trial_mountain_alpha/normal/ai/ If you try redownloading the track from that link and uploading it to ACSM again does that fix the issue?