DT expects 46 seconds to be lost

Hello, I use Server Manager 2.1.5 for Windows, installed on Windows Server 2016 x64 Standard Edition.

When a driver serves a Drive Thru, server expects 46 seconds to be lost by the driver (a message shows this requirement). If the car takes less than 46 seconds from the begining of the pitlane to the end the DT is not considered served and driver has to do it again. Why this happens? How can I change It? I didn’t find any option about this.

In the other hand, I have configured DRS acording F1 rules. When a car is within 1s with the car in front at the detection point Server shows a “DRS enable” message. However, if the diference of time at the start of the DRS zone is again more than 1s Server penalizes if driver uses DRS. This is very confuse and not real. Are there any way to solve this?

Thanks for support.

We’ve had a discussion about this on our Discord, but I’ll keep this thread up to date in case anybody else finds this issue and ends up here :slight_smile:


The DRS thing is an odd one, it should actually work how you described (only cares about gap at detection zone, and does not in actual DRS zone), but I’ve had multiple reports of this issue. In my testing it always seems to work as expected though, I’m struggling to recreate the problem.

It is very much on my list of things to look at a bit more closely though, for the update after next (which is already feature complete).

On Drive Through:

The drive through time is calculated by checking the length of the pitlane spline and calculating how long it should take a driver to drive all the way through whilst on the pit limiter (minus a fixed percentage, can’t remember quite what it is, maybe 10% or so). That means that the time will be different for every track and if the pitlane spline was made too long (sometimes they extend around t1 + t2 etc.) the pitlane time can end up being a bit long. This is required as otherwise ACSM could report a drive through as completed incorrectly, for example if somebody drove along the pit straight at full speed close enough to the wall to register as being in the pits.

Is the calculated time for your current track longer than it takes to drive through the pits? If so you could probably fix it by recording your own pitlane splines and re-uploading the track. We could look in to adding an “override” option for the pitlane time so you can set it manually in a future update though.