ACSM not displayed correctly with NGINX reverse proxy


I am configuring a reverse proxy with NGINX in order to have a nice URL to access the server manager.

Everything almost works BUT … some parts of the manager are not well displayed. For example, I cannot access the server options, I click but the menu is not displayed. Another example, the remaining time in the current session is not displayed.

For information, I have another application which pages are displayed correctly.

If you have any idea on what to do to fix this, please let me know :wink:

Here is my NGINX configuration for ACSM:

server {
    listen 80;
    location / {
        proxy_set_header Host $host;
        proxy_pass http://X.X.X.X:Y;
        proxy_redirect off;


We have a guide for setting up an nginx reverse proxy here: HTTPS support with an Nginx Let's Encrypt reverse proxy on Ubuntu · JustaPenguin/assetto-server-manager Wiki · GitHub

I think your location block is missing the following settings:

    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";

Thank you! This fixed my problem! :wink: